Quantcast

Raspbian

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Raspbian

BrianS
After being out of action for the whole long weekend, I am back in action again.

Today I discovered something very strange.  In the past couple of months, I've had to each time re-Customize my work in progress dispostion, because upon every re-boot, the midi interface number change, as well as (sometimes) the audio output device changes as well.

Today it has stopped changing, and the LINE IN sudenly is also working, so for the moment I am using only one 4 channel amplifier instead of two, as this is much smaller footprint, and simpler setup.

Stranger things have happened in the past.

Brian.
Regards,

BrianS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raspbian

greenfox
Hi Brian 

You need to set "enumerate" MIDI devices, and cache. 

Regards 
Rick 

On 5 May 2017 9:22 pm, "BrianS" <[hidden email]> wrote:
After being out of action for the whole long weekend, I am back in action
again.

Today I discovered something very strange.  In the past couple of months,
I've had to each time re-Customize my work in progress dispostion, because
upon every re-boot, the midi interface number change, as well as (sometimes)
the audio output device changes as well.

Today it has stopped changing, and the LINE IN sudenly is also working, so
for the moment I am using only one 4 channel amplifier instead of two, as
this is much smaller footprint, and simpler setup.

Stranger things have happened in the past.

Brian.



-----
Regards,

BrianS
--
View this message in context: http://jorgan.999862.n4.nabble.com/Raspbian-tp4664894.html
Sent from the jOrgan - User mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
jOrgan-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jorgan-user

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
jOrgan-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jorgan-user
greenfox - Brisbane Queensland Australia
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raspbian

BrianS
It seems the stars were alligned yesterday, so I got excited too quickly.

Today, it is all back to normal, as it was before, I need to re-customize each time I reboot.

Brian.
Regards,

BrianS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raspbian

Pete Theisen
leave it running?


On 05/06/2017 08:54 AM, BrianS wrote:

> It seems the stars were alligned yesterday, so I got excited too quickly.
>
> Today, it is all back to normal, as it was before, I need to re-customize
> each time I reboot.
>
> Brian.
>
>
>
> -----
> Regards,
>
> BrianS
> --
> View this message in context: http://jorgan.999862.n4.nabble.com/Raspbian-tp4664894p4664907.html
> Sent from the jOrgan - User mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> jOrgan-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/jorgan-user
>

--
Regards,

Pete
https://www.facebook.com/pete.theisen.5


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
jOrgan-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jorgan-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raspbian

BrianS
I mostly do that Pete, and just switch off the amplifier inside the console.  But, with the power situation it is a problem in South Africa.  Our power is too unreliable here, we have constant power failures, be it from lack of maintenance, or our only power supplier (a monopoly) in the country, which is corrupt, say that the fuel is wet.  But then they were told that coal burns better when it is damp.  So they do load shedding whenever they feel like it.
Regards,

BrianS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raspbian

Julie Porter
In reply to this post by BrianS
> Today, it is all back to normal, as it was before, I need to re-customize each time I reboot.

In the preferences section there is a section called customize.

This has 3 options under the heading "disposition errors"  which I chose to ignore, so I do not see the annoying customize message every time I open a disposition.

I think this happens when there are warnings, like missing or bad sound font paths,  No file name in the recorder,  no path to a skin etc...

If you can get the disposition to save with no errors, The customize message may go away. 

I have also noticed that If I do not start the Arduino that sends MIDI first.  Or If I go into construction mode the jOrgan program hangs when I return to run mode and has to be force quit.

I am working mostly on a mac using the IAC driver.   I think the pi works in a similar way.  At least I see the same menus and warnings.  The option menu is in a different place,  on the pi it is under one of the other menus. 

At the moment, I am using an Arduino Leonardo as a MIDI interface on the two consoles that I am running. The user has to launch Arduino, then run the serial monitor.  I think this is so that if a different sketch needs to be uploaded there is a pause in the boot loader.  I had a Leonardo, which would not upload sketches until I re-flashed the boot loader.  The other issue, is so far the name of the Arduino in the /dev folder has not changed,  It could in which time then it would have to be restarted in the IAC driver and the Arduino Tools menu.

I have been getting a lot of feedback, that as the user has to boot the mac, turn on the display, turn on the organ, launch Arduino, launch the disposition.  That it is too hard to turn the system on.    

My response so far is that this is free software and you get what you pay for.



 

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
jOrgan-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jorgan-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raspbian

BrianS
Julie,

I think my problem lies within Raspbian, and not jOrgan.

Brian.
Regards,

BrianS
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raspbian

John Reimer
Administrator
In reply to this post by Julie Porter
Julie Porter wrote
I have been getting a lot of feedback, that as the user has to boot the
mac, turn on the display, turn on the organ, launch Arduino, launch the
disposition.  That it is too hard to turn the system on.
Julie,

Of course, this process is not inherent in jOrgan itself. On my console set-up, using Windows 8.1, and Jack along with the VST reverb Hibiki and the onboard sound, I only need to press the laptop power switch, and the jOrgan disposition last used turns up, in full-screen mode. One can turn off with another brief press on the power switch, but I prefer usually to press the Windows key and power off with two more presses (it's a touch screen).

John Reimer
Loading...